A versão 5.2 do Winamp corrige novas falhas de segurança encontrada no popular tocador de conteúdo multimídia da AOL. As vulnerabilidades causam o travamento do programa e, possivelmente, a execução de código malicioso. O download e a instalação da nova versão, que corrige diversos bugs no programa, incluindo as novas vulnerabilidades, é recomendado.

As falhas estão presentes no modo que o Winamp processa arquivos de listas de reprodução (M3U), assim como a falha corrigida no fim de janeiro que foi utilizada por criadores de spywares para infectar usuários com diversas pragas digitais.

Um estouro de pilha ocorre quando o programa tenta abrir um arquivo M3U feito especialmente para explorar uma das vulnerabilidades, ocasionando o travamento do mesmo.

A empresa de segurança Secunia afirma, em um alerta, que a execução de código por meio da falha ainda não foi provada, mas pode ser possível. O risco não pode ser ignorado e a atualização é indispensável.

Outros programas do gênero, como o Windows Media Player, não são afetados pela falha. Se você possui o Winamp instalado e ele está configurado para abrir arquivos M3U, no entanto, você está vulnerável e deve desinstalar o Winamp ou atualizá-lo para a versão 5.2.

Atualizado! — Alguns usuários estão tendo problemas com a nova versão do Winamp. A atualização ainda não é 100% necessária, então pode ser uma boa idéia esperar até que os problemas sejam resolvidos. A maioria dos usuários com problemas possui Windows 98, mas usuários com Windows XP também tiveram problemas. Você pode conferir os fóruns do Winamp onde os usuários avisaram dos problemas na nova versão.

Anúncios

Escrito por Altieres Rohr

Jornalista e tradutor. Editor dos sites Linha Defensiva e Garagem 42 e colunista de Segurança Digital no portal G1 da Rede Globo.

2 Comments

  1. Manolo Fagunder 28/02/2006 às 08:02

    Infelizmente atualizei meu Winamp da versão 5.13 para a 5.2 e sofri tanto com problemas de travamentos simplesmente ao fechar o programa que fui obrigado a voltar para a versão 5.13.

    Uso o windows 98, espero que o problema não ocorra na maquina de vocês tambem.

    Manolo

    Curtir

  2. Renato Wrath 01/03/2006 às 01:15

    Enfrentei os mesmos problemas aqui com o Winamp 5.2

    Tambem uso o windows 98SE.

    Curtir

Comentários encerrados.